PHP Hosting


We are happy to announce that PHP 5.4.28 and PHP 5.5.12 is now available in PHP Selector

PHP 5.4.28 and PHP 5.5.12 are the latest stable version of the PHP 5.4.x branch and PHP 5.5.x branch respectively.

To choose your PHP version and extension, please head over to your cPanel --> Select PHP Version

PHP Selector is available for all US Web Hosting servers. 

Important Notes:-
- PHP 5.4 is not compatible with Magento which is below version 1.9 and did not implement the PHP 5.4 patch
- PHP 5.5 is not compatible with Magento which is below version 1.9.1


June 6th 2014 Update: PHP 5.4.29 and PHP 5.5.13 is now available in PHP Selector. 

July 10th 2014 Update: PHP 5.4.30 and PHP 5.5.14 is now available in PHP Selector. 

August 28th 2014 Update: PHP 5.4.32 and PHP 5.5.16 is now available in PHP Selector. 

September 23rd 2014 Update: PHP 5.4.33 and PHP 5.5.17 is now available in PHP Selector. 

October 21st 2014 Update: PHP 5.4.34 and PHP 5.5.18 is now available in PHP Selector. 

November 18th 2014 Update: PHP 5.4.35 and PHP 5.5.19 is now available in PHP Selector. 

December 23rd 2014 Update: PHP 5.4.36 and PHP 5.5.20 is now available in PHP Selector. 


Thursday, May 15, 2014





« Back